Firmware: A-410 [01 Apr. 2014] | A-400 [12 Mar. 2014] | C-300 [13 Feb. 2014] | A-300 [24 Feb. 2014] | C-200 [11 July 2013] | A-200/A-210 [11 July 2013] | Popbox V8 [3 Dec 2013]

Just got your NMT | WIKI has the answers | Search the forum | Forum Rules/Policy | Firmware & Official NMT News | Popcornhour manuals



User(s) browsing this thread: 1 Guest(s)
Thread Closed 
[transmission] Transmission 1.76 + DHT download and discussion (OLD THREAD)
11-15-2008, 11:37 AM
Post: #61
RE: [transmission] Transmission 1.40 FINAL
how do you get the gaya work cant get it work i installed 1.40 but the adress http://localhost.drives:8883/HARD_DISK/t.../index.cgi
dosnt work..
the web interface works grate...
in the gaya can i unrar files there?
Find all posts by this user
11-15-2008, 12:02 PM (This post was last modified: 11-15-2008 12:08 PM by Borg.)
Post: #62
RE: [transmission] Transmission 1.40 FINAL
Yes this is HD (1080p 50 Hz) screen.


Angelkiller try this :
Code:
http://xxx.xxx.xxx.xxx:8883/webservices.cgi?%7FhiDe=1&%7Fpg=1&%7Fname1=Gaya_Torrent&%7Furl1=http%3A%2F%2Flocalhost.drives%3A8883%2FHARD_DISK%2Ftransmission-nmt%2Findex.cgi&%7Fname2=&%7Furl2=&%7Fname3=&%7Furl3=&%7FSave=save
Copy to your browser ( eg. FireFox or IE) - this link create in WebServices link "Gaya_Torrent" and it works for me.

ps. xxx.xxx.xxx.xxx - address ip your popcorn
Find all posts by this user
11-15-2008, 01:12 PM
Post: #63
RE: [transmission] Transmission 1.40 FINAL
(11-15-2008 12:02 PM)Borg Wrote:  Yes this is HD (1080p 50 Hz) screen.


Angelkiller try this :
Code:
http://xxx.xxx.xxx.xxx:8883/webservices.cgi?%7FhiDe=1&%7Fpg=1&%7Fname1=Gaya_Torrent&%7Furl1=http%3A%2F%2Flocalhost.drives%3A8883%2FHARD_DISK%2Ftransmission-nmt%2Findex.cgi&%7Fname2=&%7Furl2=&%7Fname3=&%7Furl3=&%7FSave=save
Copy to your browser ( eg. FireFox or IE) - this link create in WebServices link "Gaya_Torrent" and it works for me.

ps. xxx.xxx.xxx.xxx - address ip your popcorn

Tanks for the help but i cant get it work.
maybe its something wrong with the transmission installation i dont get a done while installing just get install to disk and after that nothing happens but the transmisson is 1.40 if i look at a tracker it reports 1.40...
i got a HDX-1000 if that could be the problem
or do i have to uninstall the previous installation of transmisson?

http://192.168.1.10:9091/transmission/web/
i get the link in my NMT
Find all posts by this user
11-15-2008, 02:09 PM (This post was last modified: 11-15-2008 07:24 PM by Ger Teunis.)
Post: #64
RE: [transmission] Transmission 1.40 FINAL
(11-15-2008 01:12 PM)Angelkiller Wrote:  i got a HDX-1000 if that could be the problem
or do i have to uninstall the previous installation of transmisson?

http://192.168.1.10:9091/transmission/web/
i get the link in my NMT

I would suggest starting from a clean NMT-apps installation.
More information is available here


Please note: download the firmware for the HDX-1000 instead of the popcorn ofcourse.
(11-15-2008 11:32 AM)Squeek Wrote:  Sorry, forgot to mention, I got the gaya page working. its very wiiiiiiide, the page is about twice the width of the screen, and there are huuuge gaps between the end of the torrent name and the curvy graphic to round off the box...but that could be because I have some torrents with long names, haven't had time to investigate properly. I'm currently seeding about 60 torrents, so at some point I'll dump them temporarily, and add a couple back in with short names, see if this makes it more usable. Oh actually, a thought occurs - is this screen built around HD? I'm running on an SD tv, would this make a difference? I seem to recall the btpd front end switches between sd and hd, as well as the two different versions depending on whether the request comes from the local PCH or a PC.

What would be nice would be if these files could somehow be dumped in the same sybhttpd directory as the existing bt client, and viewed via http://popcorn:8883 - am I right in thinking you currently still need to have localhost.drives in you hosts file? if you could dump it in the existing web root then I'd finally be able to monitor my transmission torrents from my locked down, IE-only work PC. then I'd just need an 'add torrent' function and I'd be truly sorted Big Grin

Currently the screen optimized for WideScreen indeed. Non-widescreen is not fully supported at the moment, but may be added later.

What I could do is add a length check on the torrent's filename and if it gets too wide just shorten it like this:
"Very long .... filename" (just cut a piece out of the middle and substitute it with ...).

About adding torrents: please look at the TorrentWatch a forum member created, tip!

Easy way of installing software on your NMT using just your mouse: NMT Community Software Installer
Visit this user's website Find all posts by this user
11-15-2008, 02:24 PM (This post was last modified: 11-15-2008 02:42 PM by skogsmaskin.)
Post: #65
RE: [transmission] Transmission 1.40 FINAL
I figured out my problem - had a look at the installer .cgi script.

It was related to my USB-disk hack. I have two partitions. /dev/sda1 which contains the NMT apps (syb8634) and /dev/sd3 which is my media partition. HARD_DISK apparently should link to the media partition (where Download, Music etc. is) because this is where the Gaya interface gets installed from the script.

Gaya interface works well now - my bad.
Find all posts by this user
11-15-2008, 03:11 PM
Post: #66
RE: [transmission] Transmission 1.40 FINAL
And, how to downgrade to have the 1.34 version... because my private tracker don't accept the 1.4 Sad ?

Thank you.
Find all posts by this user
11-15-2008, 06:24 PM
Post: #67
RE: [transmission] Transmission 1.40 FINAL
(11-14-2008 07:43 AM)_tm_ Wrote:  
(11-13-2008 11:23 PM)Ger Teunis Wrote:  
(11-13-2008 09:58 PM)_tm_ Wrote:  Hello,

Even though I was able to install the beta2 version of transmission, I cannot install the final version..
the error I get is "opt/sybhttpd/localhost.drives/HARD_DISK/transmission-installer.cgi: line 143: syntax error: word unexpected (expecting "in")

..any ideas?

That is very weird, I just did test it again. Downloaded the zip, and installed it with no problems at all. Could you try again, stop the torrent, redownload unzip etc etc.

I will try again tonight - as soon as I get home - and will post the results..
From what I've seen, the difference from beta2 to final is the addition of torrentwatch and the Gaya interface.. Which means that if I don't use these two, there is really no difference in upgrading to final, correct?

Hello all,

I found out what the problem was..
For some strange reason if I FTP the files to the root folder, I cannot install anything.. It gives me all sorts of errors like the one above.
The problem goes away, if I copy the files from my computer via network, ftp to the box, change permissions to 755 and do the procedure normally.. The ftp client I use is FileZilla
Find all posts by this user
11-16-2008, 10:11 AM
Post: #68
RE: [transmission] Transmission 1.40 FINAL
(11-15-2008 03:11 PM)mitchoum Wrote:  And, how to downgrade to have the 1.34 version... because my private tracker don't accept the 1.4 Sad ?

Thank you.

There is no 1.34 release made for the NMT. I have even scanned the forums of transmission itself and there are some upload problems with the 1.34 release.

A 1.33 release is available on this forum post.

Hope that one is not blocked!

Easy way of installing software on your NMT using just your mouse: NMT Community Software Installer
Visit this user's website Find all posts by this user
11-16-2008, 02:24 PM
Post: #69
RE: [transmission] Transmission 1.40 FINAL
Hello.

How to uninstall transmission from the system?

Thank you.
Find all posts by this user
11-16-2008, 03:31 PM
Post: #70
RE: [transmission] Transmission 1.40 FINAL
(11-16-2008 10:11 AM)Ger Teunis Wrote:  
(11-15-2008 03:11 PM)mitchoum Wrote:  And, how to downgrade to have the 1.34 version... because my private tracker don't accept the 1.4 Sad ?

Thank you.

There is no 1.34 release made for the NMT. I have even scanned the forums of transmission itself and there are some upload problems with the 1.34 release.

A 1.33 release is available on this forum post.

Hope that one is not blocked!
My tracker allow Transmission 1.40 but in build 7084... not the version 7096. Is it possible tu change the number of the build?

Thank you.
Find all posts by this user
11-16-2008, 05:59 PM
Post: #71
RE: [transmission] Transmission 1.40 FINAL
Found a problem. Seems command
kill transmission-daemon-140 1>/dev/null 2>/dev/null
from clutch don't work. I'll try to stop transmission with command
/mnt/syb.../server/clutch stop
get transmission stopped
and then use ps command, and transmission threads still working.
pidof transmission-daemon-140 - returns ... nothing
I try to kill transmission process with
killall `pidof transmission-daemon-140`
and get very interesting result. I try to run that command 3 times and after last transmission was killed.
Start transmission again with /mnt/syb.../server/clutch start and
try to kill transmission. check processes - transmission is runnng.
launch pidof transmission-daemon-140 - nothing.
Can't understand what happen. Any ideas?
Find all posts by this user
11-16-2008, 06:38 PM (This post was last modified: 11-16-2008 06:45 PM by Ger Teunis.)
Post: #72
RE: [transmission] Transmission 1.40 FINAL
(11-16-2008 02:24 PM)coolparty Wrote:  Hello.

How to uninstall transmission from the system?

Thank you.

I would suggest starting from a clean NMT-apps installation.
More information is available here
(11-16-2008 05:59 PM)papka__ Wrote:  Found a problem. Seems command
kill transmission-daemon-140 1>/dev/null 2>/dev/null
from clutch don't work. I'll try to stop transmission with command
/mnt/syb.../server/clutch stop
get transmission stopped
and then use ps command, and transmission threads still working.
pidof transmission-daemon-140 - returns ... nothing
I try to kill transmission process with
killall `pidof transmission-daemon-140`
and get very interesting result. I try to run that command 3 times and after last transmission was killed.
Start transmission again with /mnt/syb.../server/clutch start and
try to kill transmission. check processes - transmission is runnng.
launch pidof transmission-daemon-140 - nothing.
Can't understand what happen. Any ideas?

Interesting, did you wait long enough for the daemon to close correctly? The daemon will try to close himself nicely. This may take some time!
A "killall transmission-daemon-140" did seem to do the trick, after a few seconds.

Easy way of installing software on your NMT using just your mouse: NMT Community Software Installer
Visit this user's website Find all posts by this user
11-16-2008, 08:34 PM (This post was last modified: 11-16-2008 08:43 PM by papka__.)
Post: #73
RE: [transmission] Transmission 1.40 FINAL
(11-16-2008 06:38 PM)Ger Teunis Wrote:  
(11-16-2008 02:24 PM)coolparty Wrote:  Hello.

How to uninstall transmission from the system?

Thank you.

I would suggest starting from a clean NMT-apps installation.
More information is available here
(11-16-2008 05:59 PM)papka__ Wrote:  Found a problem. Seems command
kill transmission-daemon-140 1>/dev/null 2>/dev/null
from clutch don't work. I'll try to stop transmission with command
/mnt/syb.../server/clutch stop
get transmission stopped
and then use ps command, and transmission threads still working.
pidof transmission-daemon-140 - returns ... nothing
I try to kill transmission process with
killall `pidof transmission-daemon-140`
and get very interesting result. I try to run that command 3 times and after last transmission was killed.
Start transmission again with /mnt/syb.../server/clutch start and
try to kill transmission. check processes - transmission is runnng.
launch pidof transmission-daemon-140 - nothing.
Can't understand what happen. Any ideas?

Interesting, did you wait long enough for the daemon to close correctly? The daemon will try to close himself nicely. This may take some time!
A "killall transmission-daemon-140" did seem to do the trick, after a few seconds.

When I write my post - I have an idea about waiting for. Now I check it. You're right. Must wait over 20-30 seconds. Thanks. And another one problem. Gaya. Open from web services, but can't see any download/upload. The list is empty. Try Refresh button, nothing.
Find all posts by this user
11-17-2008, 12:48 PM
Post: #74
RE: [transmission] Transmission 1.40 FINAL
(11-15-2008 02:09 PM)Ger Teunis Wrote:  Currently the screen optimized for WideScreen indeed. Non-widescreen is not fully supported at the moment, but may be added later.

What I could do is add a length check on the torrent's filename and if it gets too wide just shorten it like this:
"Very long .... filename" (just cut a piece out of the middle and substitute it with ...).

About adding torrents: please look at the TorrentWatch a forum member created, tip!

figured it was just a HD/SD issue - I've chopped the html about, decided to sacrifice the download 'bar', and got it displaying nicely on my standard definition screen. I also got bored and created a 'summary' page which displays a list of title and status, together with either: upspeed and ratio for seeds, or downspeed and percentage complete for downloads. I still need to 'pretty it up' but I can now either stop and start my torrents from your view (4 to a page), or just quickly see how everything is doing (25 to a page) - this helps when you have 60 torrents on the go and just want to see if one has finished downloading yet!

Oh, and I'm a long time fan of TorrentWatch, but thanks for the tip! I think my problem is a little longwinded, but here goes...I've currently got Torrentwatch dropping my 'regular' tv downloads from public trackers into btpd, and I have 8883 mapped through my router so I can access my btpd interface from work - so I can stop stuff once its seeded enough, and I can also add ad-hoc downloads here if I see something different I want to grab - a movie or whatever.
I then use Transmission for private trackers, partly to keep my btpd list 'clean' (as I tend to seed private stuff for a long time and don't want it cluttering up the btpd interface I'm trying to quickly check at work!), and partly because several private sites banned btpd.

The downside is that I only have access to IE at work, so can't get to the clutch interface, even I map the ports and stuff, as it doesn't work in IE.
So currently if I want to add an ad-hoc torrent (not one of my regulars) and it comes from a private site, I can't do it from work. A simple UI similar to what you've started, but with the 'upload' functionality that the btpd screens have, plus the ability to get to it via the popcorn IP, rather than the localhost.drives hostname, would plug that gap for me!

I guess Syabas will, at some point, replicate the btpd screens for transmission, and allow me to manage things in the same way...

Anyway, long and the short - I now have a transmission monitoring tool for the actual NMT, which is great Smile Thankyou!
Find all posts by this user
11-17-2008, 02:02 PM (This post was last modified: 11-17-2008 02:08 PM by struttler.)
Post: #75
RE: [transmission] Transmission 1.40 FINAL
I still can't get the gaya interface to work ? I've checked and the torrent service is working ok via firefox, I do have a hard disk installed and everything else is working ok. Its a fresh install of both NMT apps and transmission version 1.40 .... any ideas anyone ?

I dont have to change anything in the link that I type in via the remote. Its litterally what it says, I don't have to change the hostname or anything ?

*** fixed it, spelling error all seems ok now.
Find all posts by this user
Thread Closed 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [100/200/300/400] Transmission - v2.82 - CSI vaidyasr 168 19,443 Yesterday 07:12 PM
Last Post: Adelscott
  CSI transmission installer 2.42 or older noharm 2 234 04-11-2014 06:24 PM
Last Post: noharm
Lightbulb Torrentexpander: automatic renamer | build .nfo | download poster & fanart | NMJ Jannyy 199 56,768 04-06-2014 11:49 PM
Last Post: mrjaffa
  Transmission How To Automate Torrent Download Pinjosi 2 713 03-19-2014 05:33 PM
Last Post: Pinjosi
  [ Transmission CSI ] v2.71-dath1 (21 October 2012) DathRarhek 471 180,790 03-17-2014 09:16 PM
Last Post: Umibozu
Star NZBGet 9.0/10.0 discussion hugbug 496 97,560 03-16-2014 03:40 PM
Last Post: Mercury147
  Download folder empty cyliyu 14 963 03-06-2014 09:19 AM
Last Post: Willem53
  Download to NAS or other networked storage. kerberosvx 2 1,369 01-26-2014 11:57 PM
Last Post: IamFluff
  Autorename and download? mrjaffa 4 752 01-06-2014 11:34 PM
Last Post: mrjaffa
  Transmission and Mac - Unable to save resume file: No such file or directory jfreytag 2 1,403 01-06-2014 06:17 PM
Last Post: jfreytag

Forum Jump: