Firmware: A-410 [01 Apr. 2014] | A-400 [12 Mar. 2014] | C-300 [13 Feb. 2014] | A-300 [24 Feb. 2014] | C-200 [11 July 2013] | A-200/A-210 [11 July 2013] | Popbox V8 [3 Dec 2013]

Just got your NMT | WIKI has the answers | Search the forum | Forum Rules/Policy | Firmware & Official NMT News | Popcornhour manuals



User(s) browsing this thread: 1 Guest(s)
Thread Closed 
YAMJ & LLink index.htm auto-load
12-19-2008, 04:16 PM
Post: #1
YAMJ & LLink index.htm auto-load
So I've successfully gotten YAMJ up and running on my Linux server with LLink as the network source. All my media is on my server, with no hard dive in the popcornhour.

My only problem is getting link to serve up the YAMJ index.htm file properly.

I can browse the index file using the "documents" choice through the Samba share, and it cues up the movie properly. But LLink's option to serve up the index.html file rather than the directory listing is not working. I created a soft link using "ln -s index.htm index.html" just in case LLink needs the "L" on the end. The option is enabled in LLink to return the index.html file. Is there something I'm missing in the Samba setup?

to sum up....
"Video/Movies" directory contains all my movies, the YAMJ index.htm file & Jukebox directory, and a soft link called index.html that points to the index.htm file. The root LLink directory is the "Video" directory. LLink should return the index.htm(l) file when I click on the Movies directory, but it errors out. If I delete the soft link, then LLink will return the directory listing.

Thanks in advance for any help.
Find all posts by this user
12-19-2008, 06:31 PM
Post: #2
RE: YAMJ & LLink index.htm auto-load
You have checked that the conf file contains OPT|SEND_INDEX=1 ?

Audio, video, disco - I hear, I see, I learn.
Wiki. Wiki? Wiki!
Find all posts by this user
12-19-2008, 09:29 PM (This post was last modified: 12-19-2008 09:47 PM by ndoggac.)
Post: #3
RE: YAMJ & LLink index.htm auto-load
(12-19-2008 06:31 PM)dc11ab Wrote:  You have checked that the conf file contains OPT|SEND_INDEX=1 ?

confirmed = 1, if I dont' put the index.html link pointing to the index.htm then the directory listing is returned, as soon as I put the link in, it returns an error.
Also made sure LLink was restarted for changes to take effect. Any other conf file settings that may affect this?
Find all posts by this user
12-19-2008, 09:32 PM
Post: #4
RE: YAMJ & LLink index.htm auto-load
When I get the chance I'll try to reproduce (I don't use YAMJ or other 'static' jukebox), but perhaps someone else can confirm this error. It seems lundman might have to take a look upon this.

Audio, video, disco - I hear, I see, I learn.
Wiki. Wiki? Wiki!
Find all posts by this user
12-20-2008, 06:47 PM
Post: #5
RE: YAMJ & LLink index.htm auto-load
which jukebox do you use?
Find all posts by this user
12-20-2008, 07:01 PM
Post: #6
RE: YAMJ & LLink index.htm auto-load
At times I use the built-in jukebox skin(s); jukebox and kamaishi_skies, but normally I just have a file list.

Audio, video, disco - I hear, I see, I learn.
Wiki. Wiki? Wiki!
Find all posts by this user
12-30-2008, 03:29 PM
Post: #7
RE: YAMJ & LLink index.htm auto-load
(12-19-2008 09:29 PM)ndoggac Wrote:  confirmed = 1, if I dont' put the index.html link pointing to the index.htm then the directory listing is returned, as soon as I put the link in, it returns an error.
Also made sure LLink was restarted for changes to take effect. Any other conf file settings that may affect this?

Hello, I'm a long time reader, first time poster...

I've always had this same issue. I really like both yamj and llink. They are both
wonderful tools. I really wish llink would serve up the yamj index.htm
file. I also have the OPT|SEND_INDEX=1 enabled in the llink.conf file
but it does not appear to work. I am using the skin by Mikesv which
is really nice, but not as nice for movies as the yamj created index.htm file.

Thanks for any insight or advice.

T.
Find all posts by this user
01-02-2009, 02:50 AM
Post: #8
RE: YAMJ & LLink index.htm auto-load
just thought I would mention I am using the latest version of LLink (2.2.0) with the 1.0.13 version of YAMJ using default skin.
Find all posts by this user
01-02-2009, 06:43 AM
Post: #9
RE: YAMJ & LLink index.htm auto-load
Have you tried copying index.htm to index.html to see if it does not like symlinks? When you say it errors out, what is the error? Have you run it with debug output?
Visit this user's website Find all posts by this user
03-02-2009, 01:55 AM (This post was last modified: 03-02-2009 01:55 AM by ndoggac.)
Post: #10
RE: YAMJ & LLink index.htm auto-load
(01-02-2009 06:43 AM)lundman Wrote:  Have you tried copying index.htm to index.html to see if it does not like symlinks? When you say it errors out, what is the error? Have you run it with debug output?

Tried it both ways with no luck. I noticed you have in your todo list to add ROOT to href, is this a result of the current method not working properly?

YAMJ creates index.htm file, tried creating a soft link to it called index.html, didn't work, then moved index.htm file to index.html and creating a link to it called index.htm. Either way works through a Samba share though.
I have not run it with debug output.

Thanks in advance for any help.
Find all posts by this user
03-02-2009, 02:27 AM
Post: #11
RE: YAMJ & LLink index.htm auto-load
llink does only look for index.html currently, although it is easy to change:
Code:
findex = misc_strjoin(node->disk_path, "index.html");
        if (findex && !stat(findex, &node->stat)) {
            // Fix in-disk path
            SAFE_FREE(node->disk_path);
            node->disk_path = findex;
            // Fix logical path, used for mime-type and MACROS
            findex = misc_strjoin(node->path, "index.html");

Any particular reason why YAMJ is using just .htm? That's a requirement of Win95, is that really what YAMJ is compatible with? Alternately, I will add the index.html string to the conf so its configurable.

The ROOT|HTML is so you can have a root entry that is just a URL, instead of having to bother with a index.html file.
Visit this user's website Find all posts by this user
03-10-2009, 12:15 AM
Post: #12
RE: YAMJ & LLink index.htm auto-load
@ ndoggac

I just installed YAMJ on my NAS. I also use llink and I ran into the same problem as you did: if the file is named "index.htm", llink will only show the directory listing; if the file is named "index.html", llink will show an error message.

I've found the cause: I installed the index file in a subdirectory and that does not work.
In order for llink and YAMJ to work, two conditions need to be met:
- the index file must be renamed to "index.html"
- the index file must be in a llink root folder

You can define multiple root folders in llink. Just create the folders on your NAS and refer to them in the llink.conf file. For instance, I have the following lines in my llink.conf file:
ROOT|path=/volume1/video/Filmdatabase/|SUBDIR=Filmdatabase
ROOT|path=/volume1/video/Grote mensen/|SUBDIR=Grote mensen
ROOT|path=/volume1/video/Kleine mensen/|SUBDIR=Kleine mensen
ROOT|path=/volumeUSB1/usbshare/|SUBDIR=USB archief

The YAMJ information is written to the first root, the movies themselves are on the 3 other roots. It works perfectly.

Suc6
Ben
Find all posts by this user
Thread Closed 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Bierdopje auto-sub for A-110 BeeVee 19 5,623 12-27-2013 09:12 AM
Last Post: Djiest
  MyLil Movie Jukebox no index html file? whyioughta 2 2,327 12-07-2010 03:08 AM
Last Post: whyioughta
  Can't load Themes with CSI narfnd 1 2,429 11-03-2010 07:20 PM
Last Post: joserobleda
  [AUDIO] lastfm script (bookmarks, auto-login, etc.) mk11 81 45,771 10-09-2010 01:45 AM
Last Post: opfeifer
  Custom Index link (href) help wanted pbusardo 7 9,145 09-23-2010 03:32 AM
Last Post: pbusardo
  Index.htm on usb....for startup hispanico 4 2,649 06-30-2010 09:25 AM
Last Post: hispanico
  help with auto unrar script. kiranos 0 2,090 05-15-2010 10:24 AM
Last Post: kiranos
  RAR support in gaya / mono / YAMJ x0r 1 2,361 03-09-2010 01:19 AM
Last Post: lundman
  Auto_Mount v0.1 - Script to auto mount USB drives with NAME vaidyasr 41 20,146 02-12-2010 03:22 AM
Last Post: vaidyasr
  Llink rar archive not showing content imtcb 15 6,441 12-01-2009 01:29 PM
Last Post: bengt

Forum Jump: